• 2021年5月8日 上午6:24

超的快乐一天

做个人

cisco GRE vpn配置基本原理

唯一一线

唯一一线

11月 16, 2020

网络环境

张三位于公司上海分部,李四位于公司北京分部

上海分部公网ip : 100.1.1.1/24

北京分部公网ip : 100.1.1.2/24

张三内网ip: 192.168.1.1/24

李四内网ip: 192.168.2.1/24

需求描述

现在上海分部要与北京分部之间建立隧道vpn通信 使张三所在的上海分部的网段(19.168.1.0/24)能直接与李四北京分部的网段(192.168.2.0/24)能直接通信

R1配置

//配置隧道
Router(config)#interface tunnel 0 
//配置隧道ip    
Router(config-if)#ip address 192.168.3.1 255.255.255.0
配置隧道源地址 为本身自己的公网地址 : 100.1.1.1
shanghai(config-if)#tunnel source 100.1.1.1
//配置隧道目的地址 目的地址为所建立vpn通信对方的公网地址
shanghai(config-if)#tunnel destination 100.1.1.2
exit
//配置隧道静态路由 指向vpn连接的内网 路由路线指向隧道
shanghai(config)#ip route 192.168.2.0 255.255.255.0 tunnel 0

R2配置

R2也是同理

//配置隧道
Router(config)#interface tunnel 0 
//配置隧道ip    
Router(config-if)#ip address 192.168.3.2 255.255.255.0
配置隧道源地址 为本身自己的公网地址 : 100.1.1.2
shanghai(config-if)#tunnel source 100.1.1.2
//配置隧道目的地址 目的地址为所建立vpn通信对方的公网地址
shanghai(config-if)#tunnel destination 100.1.1.1
exit
//配置隧道静态路由 指向vpn连接的内网 路由路线指向隧道
shanghai(config)#ip route 192.168.1.0 255.255.255.0 tunnel 0

分析GRE包

目的地址是先从公网传输到内网的源地址到内网目的地址

公网源地址到目的地址 和 内网源地址到目的地址中间 还是GRE包头

GRE概述

GRE概述

  1. 优点

    支持IP网络作为承载网络、支持多种协议、支持IP组播、配置简单、容易部署

  2. 缺点

    缺少保护功能,不能执行如认证、加密、以及数据完整性检查这些任务。

  3. 总结

    因为安全上的限制,GRE通常不能用作一个完整的VPN解决方案;然而它可以和其他的解决方案结合在一起,例如IPsec,来产生一个极强大的、具有扩展性的VPN实施方案

唯一一线
Latest posts by 唯一一线 (see all)
唯一一线

唯一一线

相情不如偶遇

相关文章

发表评论

您的电子邮箱地址不会被公开。 必填项已用*标注


CAPTCHA Image
Reload Image